CommCare HQ Slowness and Instability

Incident Report for CommCare HQ

Resolved

Dear users, this issue has now been fully resolved. We appreciate your understanding and patience while we worked to resolve this problem.
Posted Apr 14, 2025 - 15:25 UTC

Update

Dear users, performance is gradually returning to normal. We will continue to monitor closely until the issue is fully resolved. Thank you for your patience and understanding.
Posted Apr 14, 2025 - 14:19 UTC

Update

Dear users, performance continues to remain in a degraded state. Our engineers are working on resolving the issue with the utmost urgency. We apologize for the inconvenience that this is causing.
Posted Apr 14, 2025 - 13:17 UTC

Update

Dear users, performance continues to remain in a degraded state. Our engineers are working on resolving the issue with the utmost urgency. We apologize for the inconvenience that this is causing.
Posted Apr 14, 2025 - 12:32 UTC

Investigating

Dear users,

We are currently experiencing some slowness on our servers, which may cause CommCare HQ to load slowly for some users. Our engineers are investigating the issue as a priority. We will keep you updated on the progress.

We apologize for the inconvenience caused.
Posted Apr 14, 2025 - 11:41 UTC
This incident affected: www.commcarehq.org (Form Builder, App Release Management, User Management, Syncs with CommCare HQ, Form Submissions, Data Exports, Project Reporting, SMS / Messaging, Bulk Case Import, CommCare APIs, Web Apps, Core Functionality).